Opened 9 years ago

Closed 9 years ago

#121 closed enhancement (duplicate)

Synchronising vuurmuur_conf and /etc/vuurmuur

Reported by: davidbrown Owned by: Victor Julien
Priority: major Milestone: undecided
Component: suite Version: 0.7
Keywords: Cc: david@…

Description

Sometimes it is quicker and easier to work with files directly in the /etc/vuurmuur tree rather than using vuurmuur_conf. For example, I use vuurmuur_conf to make a few rules, zones, etc., so that I am sure of the syntax, and then edit files manually.

This usage would be much improved if vuurmuur_conf were able to re-read the files while running, rather than just at startup (as it seems to do). For example, it should be possible to add a new service to the services directory and then use it directly in vuurmuur_conf rather than having to restart vuurmuur_conf.

Another improvement would be if vuurmuur_conf could leave comments and blank lines unchanged in the rules.conf file (perhaps it should be possible to view and add comment lines from vuurmuur_conf?). When writing something like rules.conf by hand, I prefer to add comments - vuurmuur_conf deletes them when saving.

Change History (2)

comment:1 Changed 9 years ago by davidbrown

Cc: david@… added

comment:2 Changed 9 years ago by Tiger!P

Resolution: duplicate
Status: newclosed

This is a duplicate of #23 .

Note: See TracTickets for help on using tickets.